<!-- Hier den Titel einfügen -->T I T E L
mkberlin.com :: frühjahr 2018 :: progress in constructing
 

Schwerpunkt:: TYPO3

Anmeldung am TYPO3-Backend nicht mehr möglich

Es kann immer mal wieder vorkommen, dass die TYPO3-Installation nicht mehr zugänglich ist.

Mir geht es derzeit so, weil ich eine Domain brauch-ich-nicht-mehr.de aufgegeben habe und nun den Einstiegspunkt in die Website über hab-ich-noch-frei.de realisiere. Will ich mich nun mit meinem bisherigen Benutzernamen und Kennwort anmelden, dann gelingt das nicht.

Mögliche Ursache ist eine TYPO3- Fehlkonfiguration.
Der Aufruf von hab-ich-noch-frei.de/typo3/  bietet die Anmeldung am Backend von brauch-ich-nicht-mehr.de.
Naheliegend ist nun also in TYPO3 den Wechsel der Domänenzuständigkeit einzutragen.

Die normale TYPO3-Backend-Anmeldung mit dem bekannten Benutzernamen und Kennwort an der neuen Domäne hab-ich-noch-frei.de/typo3 funktioniert nicht.
Die Anmeldung am Installations-Tool via hab-ich-noch-frei.de/typo3/install gelingt nach dem Anlegen einer neuen, leeren Datei namens ENABLE_INSTALL_TOOL und Eingabe des bekannten Kennworts.

Im Install-Tool nun den Bereich All Configuration auswählen und die folgende Anpassungen vornehmen

$TYPO3_CONF_VARS['SYS'][sitename]
von brauch-ich-nicht-mehr.de auf hab-ich-noch-frei.de

Nun wird zwar die Backend-Anmeldung an der korrekten Domäne angezeigt, der LogIn mit den bekannten Daten gelingt dennoch nicht.

Im Install-Tool den Bereich Database-Analyzer auswählen und etwas weiter unten den Punkt Create-Admin-User anklicken.

Enter username and password for a new admin user. 
You should use this function only if there are no admin users in the database, for instance if this is a blank database. 
After you've created the user, log in and add the rest of the user information, like email and real name.

Der Hinweistext verunsichert mich etwas, da es ja eigentlich schon einen TYPO3-Administrator gibt, dessen LogIn nur gerade nicht funktioniert.
Mit Mut zum Risiko erstelle ich ein notadmin.

Und schwups:

Oops, an error occurred!

$toolbarItem "shortcuts" must implement interface TYPO3\CMS\Backend\Toolbar\ToolbarItemHookInterface

More information regarding this error might be available online.

 

Nach oben